Welcome Anonymous
Fledgling
Fledgling
It is currently Wed Jun 28, 2017 4:32 pm

All times are



Post new topic Reply to topic  [ Array ]  Go to page 1, 2  Next
Author Message
PostPosted: Tue Dec 20, 2011 7:06 pm 
Offline
Emperor
Emperor
User avatar

Joined: Fri Aug 13, 2010 8:35 pm
Posts: 552
Location: central kentucky
Built a remote flash,well partly any way. The only way I can get it to flash is to hold a camera directly over the board.
I have put tape over the daylight sensor so it will thing its dark.
I have the PT coming out the bottom of the case. It is hooked up correct( I think) long leg goes in E.
I have added a video of what its doing, anybody got any clue to what is wrong.
Its running on Bowgod's code
Image


Top
 Profile  
Reply with quote  
PostPosted: Tue Dec 20, 2011 8:38 pm 
Offline
Site Admin
Site Admin
User avatar

Joined: Fri Jan 29, 2010 1:04 pm
Posts: 7453
Location: Northern Minnesota
[video]<embed width="600" height="361" type="application/x-shockwave-flash" allowFullscreen="true" allowNetworking="all" wmode="transparent" src="http://static.photobucket.com/player.swf" flashvars="file=http%3A%2F%2Fvid1177.photobucket.com%2Falbums%2Fx360%2Frickyd3%2FMOV03983.mp4">[/video]

_________________
Homebrew Reference Site
My Calendar Store
My Land


"Wilderness to the people of America is a spiritual necessity, an antidote to the high pressure of modern life, a means of regaining serenity and equilibrium."
- Sigurd Olson


Top
 Profile  
Reply with quote  
PostPosted: Tue Dec 20, 2011 8:43 pm 
Offline
Emperor
Emperor
User avatar

Joined: Fri Aug 13, 2010 8:35 pm
Posts: 552
Location: central kentucky
You make it look to easy Willy thank for fixing it, posting the video on here that is. NOW can you fix a remote slave.


Top
 Profile  
Reply with quote  
PostPosted: Tue Dec 20, 2011 8:56 pm 
Offline
Moderator
Moderator
User avatar

Joined: Mon Feb 01, 2010 5:45 pm
Posts: 4350
Location: Sussex County NJ
Rick, which pt are you using? I think the collector and emitter are opposite on the flat one vs. the round one, although I don't know if it will make a difference being that close. Also do you have a copy of the code? Make sure the cam is set to the proper program settings too.

_________________
Image trailcamkits.com


Top
 Profile  
Reply with quote  
PostPosted: Tue Dec 20, 2011 9:06 pm 
Offline
Site Admin
Site Admin
User avatar

Joined: Fri Jan 29, 2010 1:04 pm
Posts: 7453
Location: Northern Minnesota
Hey, no problem Rick. I modified the embedding feature instructions since Photobucket appears to have changed their format a bit. Hope you get your slave fixed.

viewtopic.php?f=14&t=3657&p=26747#p26747

_________________
Homebrew Reference Site
My Calendar Store
My Land


"Wilderness to the people of America is a spiritual necessity, an antidote to the high pressure of modern life, a means of regaining serenity and equilibrium."
- Sigurd Olson


Top
 Profile  
Reply with quote  
PostPosted: Wed Dec 21, 2011 4:36 pm 
Offline
Emperor
Emperor
User avatar

Joined: Fri Aug 13, 2010 8:35 pm
Posts: 552
Location: central kentucky
JDH i'm using the PT that is clear round one that is listed in the AIO parts.
I'm not using a cam it's a remote slave.
heres the code.

' Input from PT on input C.1
' Input from CDS om input ADC10
' Output to led on output B.2
' Output to trigger slave on output C.4
' Output power to PT on output C.2
' Output power to slave flash mosfet on output C.3
' Output to CDS on output C.5


Symbol Flash_Flag = b11 ' Flag to count the # of flashes seen
Symbol Fire_Flag = b12 ' Flag to fire the slave flash
Symbol TO_Counter = W1 ' Timeout counter
Symbol Slave_Refresh = B7 ' Slave refresh timer
Symbol Flash_On = C.3 ' Flash Charge Mosfet
Symbol CDS_OUT = C.5 ' Power to CDS
Symbol PT = C.2 ' Power to PT
Symbol Trigger = C.4
Symbol Led_Out = B.2
Symbol PT_In = B.0
Symbol Night_Flag = b13
Symbol CDS_Value = b10
Symbol Day = b9
Symbol Night = b8
Symbol First_Flash = b15

'********************************************

Output Flash_On
Output CDS_OUT
Output PT
Output Trigger
Input PT_In
Input B.5
Input B.0
Output Led_Out
Output C.7
Output C.0
Output B.7
Output A.0
Output B.1
Output C.1

Night = 155
Day = 144
adcsetup = %010000000000 'make adc 10 a input

disablebod

High Led_Out
pause 500
low Led_Out
pause 500
High Led_Out
pause 500
low Led_Out
pause 5000

GoSub CdsChk
IF Night_Flag = 1 Then GoSub Slave_Charge
High PT

Hintsetup %00100010
setintflags %000000010,%000000010 'activate interrupt when pinB.0 only goes high

'*********************************************************************************************

Main:


If Slave_Refresh = 40 And Night_Flag = 1 Then
GoSub Slave_Charge
EndIf


If Flash_Flag <> 0 Then inc TO_Counter EndIF ' Start counter if first flash detected
If TO_Counter = 4 then Gosub TimeOut ' Timeout here if no other flash detected. Adjust value if necessary to fit camera.
If Fire_Flag = 1 then ' Fire the flash if flag is set. Disable interrupts.
'Setint off
Gosub Fire_Flash
EndIF
GoSub CdsChk
If Night_Flag = 1 Then
Inc Slave_Refresh
EndIf
Sleep 5
Goto Main

'***************************************************************
'SUBS
'***************************************************************

Interrupt:
If hint1flag = 1 Then :Endif
First_Flash = 1
Inc Flash_Flag
hint1flag = 0
Do while pinB.0 = 1 'Loop around until the pin goes low. This is necessary in order to detect the second flash. For some reason the pin does not go low right away.
Loop
If Flash_Flag = 2 Then 'Set fire flag once second flash is detected.
Fire_flag = 1
EndIF

setintflags %000000010,%000000010 'Turn interrupts back on.
Return



Fire_Flash:
SetFreq m16

Do
Loop while flash_flag <> 2
High Trigger
pause 400
Low Trigger
pause 100
'High Led_Out
'pause 250
'low Led_Out
'pause 250
' High Led_Out
'pause 250
'low Led_Out
'+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++pause 250
Flash_Flag = 0 ' Reset flags
TO_Counter = 0
SetFreq m8
Gosub Slave_Charge
GoTo Flash_Exit


Flash_Exit:
Fire_flag = 0
First_Flash = 0
Flash_Flag = 0
'setintflags %000000010,%000000010 'Turn interrupts back on.
SetFreq m8
'sertxd ("Flash Exit ",13,10)

Return


TimeOut:
Fire_flag = 0
Flash_Flag = 0 ' Reset flags
TO_Counter = 0
Gosub Flash_Led ' Flash Led to indicate time out.
Return

Flash_Led:
For b0 = 1 To 50
Toggle Led_Out
pause 20
Next
Return


Slave_Charge:
'High Led_Out
pause 10
High Flash_On
Pause 8000 ' charge for 10sec
Low Flash_On
pause 10
'Low Led_Out
Slave_Refresh = 0 ' restart our 10min period
Return

CdsChk:
High CDS_Out 'Turn on pin to supply voltage to cds voltage divider
readadc 10 , CDS_Value ' Read light value
Low CDS_Out 'Turn off voltage divider
If Night_Flag = 1 And CDS_Value >= Day Then
GoTo CdsChk_Exit 'already set and Still dark so we exit
Else
Night_Flag = 0 ' already set and Daylight so clear flag
EndIf
If Night_Flag = 0 And CDS_Value >= Night Then
Night_Flag = 1 ' Its dark so set flag
Gosub Slave_Charge
Else
Night_Flag = 0 ' Daylight so clear flag
EndIf

CdsChk_Exit:

Return


Top
 Profile  
Reply with quote  
PostPosted: Wed Dec 21, 2011 8:13 pm 
Offline
Moderator
Moderator
User avatar

Joined: Mon Feb 01, 2010 5:45 pm
Posts: 4350
Location: Sussex County NJ
I mean the cam you are using to trigger the slave, make sure it's set to the proper settings. If the af allum is on or red eye reduction it could mess things up. What cam are you using?

_________________
Image trailcamkits.com


Top
 Profile  
Reply with quote  
PostPosted: Wed Dec 21, 2011 9:18 pm 
Offline
Emperor
Emperor
User avatar

Joined: Fri Aug 13, 2010 8:35 pm
Posts: 552
Location: central kentucky
My bad, I'm using a s40. I have tried using about every setting on it.
I have also used a p32 a vivitar 2600 all had the same results it well only work if directly over the board.


Top
 Profile  
Reply with quote  
PostPosted: Wed Dec 21, 2011 10:12 pm 
Offline
Emperor
Emperor

Joined: Tue Feb 16, 2010 6:19 am
Posts: 758
Make sure your pt is not wired backwards.


Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 22, 2011 3:48 am 
Offline
Moderator
Moderator
User avatar

Joined: Mon Feb 01, 2010 5:45 pm
Posts: 4350
Location: Sussex County NJ
If the pt is the round one (the one that looks like an led) the you should be right, the long leg is the emitter and goes to e on the board and the short leg should go to c on the board.

Rick, do you have all the components on the board or just what's needed for the slave?

Also, is the red led flashing on the board after the slave fires?

_________________
Image trailcamkits.com


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ Array ]  Go to page 1, 2  Next

All times are


Who is online


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group