S 600 problem goes to 2006 date with every turn on

Post Images and Information on Your Homebrew Builds
Post Reply
User avatar
cnggack
Posts: 1883
Joined: Sun Jan 31, 2010 11:19 pm

S 600 problem goes to 2006 date with every turn on

Post by cnggack »

The batteries were dead on my s600 After resetting the date I clicked ok but when I shut off the camera and turned it on again the same 2006 date screen came on just like it does after installing new batteries when the internal battery is dead .I must have reset it ten times but cant get it to work.
while I'm on s600 problems I have another that that keep saying reinsert memory stick C;13:01 and beeps I did have a piece of old card stuck in but got that out .I think I bent something trying to get the piece out.
User avatar
kdornski
Posts: 1052
Joined: Sun Jan 31, 2010 8:56 pm

Re: S 600 problem goes to 2006 date with every turn on

Post by kdornski »

Did you try putting new batteries in the camera and let it sit for a day or two to see if internal battery in the camera recharges?
User avatar
ghosthunters
Posts: 3757
Joined: Sat Feb 02, 2013 2:56 pm
Location: Central Saskatchewan, Canada

Re: S 600 problem goes to 2006 date with every turn on

Post by ghosthunters »

I have a couple that I have to reset all the settings each time I change the internal batteries ... getting pretty quick now.

I am gonna try and leave the internal and change the externals only and I presume I won’t have to reset the date and all the settings.


Sent from my iPhone using Tapatalk
User avatar
cnggack
Posts: 1883
Joined: Sun Jan 31, 2010 11:19 pm

Re: S 600 problem goes to 2006 date with every turn on

Post by cnggack »

Ive had new lithiums in for three days still does same thing I have lots of cams that internal battery is no good but those only have the date page pop up the first time you put new AAs in reset date and time and they are good until AA batterys die again This camera will not operate with control board because when the controller turns the cam on it goes to date and time page and will not work until time is set.
User avatar
johnnydeerhunter
Posts: 4384
Joined: Mon Feb 01, 2010 5:45 pm
Location: Sussex County NJ

Re: S 600 problem goes to 2006 date with every turn on

Post by johnnydeerhunter »

Have you tried initializing the camera? I wonder if there's a short in the memory card holder or if possible maybe a little battery corrosion
User avatar
cnggack
Posts: 1883
Joined: Sun Jan 31, 2010 11:19 pm

Re: S 600 problem goes to 2006 date with every turn on

Post by cnggack »

Im not sure what you mean when you sat initializing I have not noticed any condensation in case have had Decicant packs in it
User avatar
cnggack
Posts: 1883
Joined: Sun Jan 31, 2010 11:19 pm

Re: S 600 problem goes to 2006 date with every turn on

Post by cnggack »

Just tried it again tonight first time it did the same second try it worked let me set date and shut off and worked board worked with it also! weird Thanks for the help
Good time Charlie
Posts: 24
Joined: Sat Mar 24, 2018 7:31 pm

Re: S 600 problem goes to 2006 date with every turn on

Post by Good time Charlie »

If you have initialed your cam and it is still doing it, your internal s600 cam Battery is dead
Post Reply